Play Store issue with Galaxy S5
Posted: 21 April 2017 05:11 AM   [ Ignore ]  
Avatar
Cadet
Rank
Total Posts:  2
Joined  2015-07-17

Just wondering, is the Galaxy S5 (specifically the SM-S902L) not supported? Other than carrier, I don’t think it has any significant differences from the other models of S5. It says the app is not compatible when I try to download it on this phone. Same goes for the 1.9.0 beta. Not sure if this is the best place for this post but the others seemed more for bugs and suggestions.

Profile
 
 
Posted: 21 April 2017 05:20 AM   [ Ignore ]   [ # 1 ]  
Avatar
Commander
RankRankRankRankRankRank
Total Posts:  1259
Joined  2017-01-08

Might also be helpful to share your Android version.

 Signature 

 

Could you please continue the petty bickering? I find it most intriguing.
~ Data, ST:TNG “Haven”

Profile
 
 
Posted: 21 April 2017 05:40 AM   [ Ignore ]   [ # 2 ]  
Avatar
Commander
RankRankRankRankRankRank
Total Posts:  1679
Joined  2017-04-11
Data1001 - 21 April 2017 05:20 AM

Might also be helpful to share your Android version.

You’re probably better off posting this in the Engineering Room. I know it’s for bugs in-game but I think that would include problems like yours (not being able to download it in the first place).

 Signature 

Player from 06th April 2017 - 09th September 2017, now retired.

LLAP

Profile